Author Topic: Testing a short test Bink video with DOOM?  (Read 70 times)

0 Members and 1 Guest are viewing this topic.

spamclark15

  • id Enthusiast
  • Jr. Member
  • **
  • Posts: 97
  • Karma: +10/-3
  • A missile-launching skyscraper with goat legs.
    • View Profile
Testing a short test Bink video with DOOM?
« on: September 24, 2017, 06:03:19 PM »
Would anyone be willing to download a bink video I've created as a test and see if it plays properly swapped out with boot_sequence.bik in DOOM 2016? I would just need to know if it displays properly or if the luma and chroma are misaligned (particularly towards the end of the video where the color on the second warning screen is rendered stretched wrong.) I only have 1 PC I can test it on to see if it's an issue on my end or with the game. The video displays properly in RAD tools but as startup for the game is the area of discrepency.

https://www.mediafire.com/file/y4ow7q3ywv0f8kq/boot_sequence.bik

The Happy Friar

  • Happy Happy Joy Joy
  • Administrator
  • Hero Member
  • *****
  • Posts: 865
  • Karma: +42/-4
  • Semi-Newbie.
    • View Profile
    • EarthQuake
Re: Testing a short test Bink video with DOOM?
« Reply #1 on: September 24, 2017, 08:35:36 PM »
The warning in red in multiple languages looks like it's shadowed by a different color, a light blue.

spamclark15

  • id Enthusiast
  • Jr. Member
  • **
  • Posts: 97
  • Karma: +10/-3
  • A missile-launching skyscraper with goat legs.
    • View Profile
Re: Testing a short test Bink video with DOOM?
« Reply #2 on: September 25, 2017, 05:15:58 AM »
So it appears different than the same screen on the original video? Bink stores information as chroma and luma separately in 3 planes as YCrCb, where green and luma are stored together as Y, the difference between red and Y as Cr, and the difference between blue and Y as Cb, and I'm noticing the problems seem to stem from the chroma part having alignment issues with the luma, which never seems to have any issues. My test of this was to take the video and make it monochrome, which on my end solves the problem. I wish I could work with the RAD devs on it but they don't respond to my e-mails so I don't have that luxury.