Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Chrissstrahl

Pages: [1]
1
I think I know now what is causing it, after reading a little.
I guess it is not steam, it is because id-Tech 4 works different from what I am used to:
https://www.iddevnet.com/doom3/code.php
Quote
All the clients are actually running the exact same game code as the server, so in theory they should never get out of sync, but as well all know, they do get out of sync.

I am assuming that I need to do something that I did not.
Probably compile client and server dll, so that they match, or something like that.

2
Thank you, that is good advice.
Most helpful information, I think I can start with that.
:)

3
Thanks, a project like this will take months, so a few days wait dosen't really hurt ;)

I will try the disk version my self anyway, so there would be no point in having two people test it.
I also think I will develop using the disk version, as I don't like all the issues I get with the steam version.

Can you give me some details for these questions ?
Just pretend they are for Doom 3, if it dosen't work out I will notice.
- How would I best start to make a multiplayer mod ?
- Unzip the pk4 ? So that I don't have to make a pk4 each time I change files
- Any commands that I should know while testing, like developer/cheats/tools

4
This is about quake4.

I have made changes to the code so it does compile in MS Visual Studio 2015 and I get a dll.
So it looks like it should all work, but it does not. The dll that i create is not loaded by the game.

I want to make a Multiplayer Mod (I know it is dead, but I don't care).
If I make any changes on the game and start a Multiplayer Server from with in the game Menu, i get the Error Message that reads:
Quote
This mod is for singleplayer only

If I delete a few files and revalidate via steam it works again (sometimes, if does not damage the fake cd-key in the process).
Again, I want to state, that this is Error Message is not from any of my dlls.

I don't remember quake4 making so much troubles 10 years ago, is it the steam version ?
I would really much appreciate, if someone could give me a few pointers on how to get a own mod working.
This is very frustrating and not at all worthy of anyone's time, so I want to avoid this issue in the future.
The Compiling of the code and the actual changes to the code, are not the problem for me at this time.
I am not sure if this is the right section, to post this in.

Pages: [1]