id Tech 4 (Doom3/Prey/Q4) > id Tech 4 Engine Coding

D3 GPL MS Community 2013 Ready to Go Compile + Tools

(1/4) > >>

The Happy Friar:
Here's the stock D3 GPL code, all ready to go to compile with MSVC Community 2013.  It will compile the tools for you.  You should just need to unzip to a folder, open the doom.sln & build all. 

here

grml4d:
i tried to compile but i have a lot of errors ...
when i launch doom3 that starts well but at new game that bugs...with a sort of square in the middle of screen
i use vcpro2013 update 4 .... i am getting update 5..

doom3 has to be updated to 1.31 or an other one version ?

i ll try to clean my windows and doom3

Snehk:
Game must be updated to 1.31 to run on compiled GPL release.

To compile you'll also need MFC and DirectX SDK, and update 5 is required too. Check this out:

https://www.katsbits.com/smforum/index.php?topic=896.0

You'll find links to required downloads, as well as instructions how to prepare GPL release straight from id's github to compile. If you're still going to use the code provided by The Happy Friar, then you will probably need only downloading required files and updating game.

grml4d:
thank you Snehk
update 5 made it ... i wonder if somebody made the same with bfg...
i tried to compile the ROE dll but that fails...

i looked the source files and saw that some "libraries" can be updated : i uploaded them at this link
https://mega.nz/#F!zIYGkK5b!pXnP_W_Plc5LqFgaMN_2fA

the files are jpeg version 9 while doom3 uses 6 , the network engine : curl and the audio ogg & vorbis .
as i start learning programming , i ask for help to update these main elements...
i hope to use the idtech4 for playing hl maps ...  O0 8)

Snehk:

--- Quote from: grml4d on July 25, 2017, 04:30:24 PM ---i looked the source files and saw that some "libraries" can be updated : i uploaded them at this link
https://mega.nz/#F!zIYGkK5b!pXnP_W_Plc5LqFgaMN_2fA

the files are jpeg version 9 while doom3 uses 6 , the network engine : curl and the audio ogg & vorbis .
as i start learning programming , i ask for help to update these main elements...

--- End quote ---

Perhaps checking the implementation in engine and checking sources for libraries would help to see how much needs to be updated. Though someone better at coding would help you better than me.


--- Quote from: grml4d on July 25, 2017, 04:30:24 PM ---i hope to use the idtech4 for playing hl maps ...  O0 8)

--- End quote ---

You mean Half-Life maps? You can add support for level format, probably easily at that, but there would be several problems. HL levels are compiled into .bsp files, compilers for Half-Life (ZHLT, VHLT) won't give you .proc and .cm required to run the engine on idTech 4. You can try to compile .map file from HL level editors (Sledge, VHE, Worldcraft) with dmap, but I'm not sure if it'd successfully compile. HL level format has numerous cirppling limitations that would make it running on id Tech 4 hard.

Navigation

[0] Message Index

[#] Next page

Go to full version