Author Topic: Disable shadows on particle lights  (Read 42 times)

0 Members and 1 Guest are viewing this topic.

EoceneMiacid

  • Full Member
  • ***
  • Posts: 132
  • Karma: +4/-15
    • View Profile
Disable shadows on particle lights
« on: April 14, 2019, 04:35:52 AM »
I think this one should be possible...

My plasmagun's projectiles has lights attached to them, so that they light up the place whenever you fire it.
This looks great, but it becomes problematic with a high enough rate of fire, especially if the projectiles bounce around and there are a lot of surfaces to bounce the light off of, and objects to cast shadows from.

I do not want to gimp the firerate to keep the framerate under control either.
Is it possible to keep the light but not the shadow casting?

The Happy Friar

  • Happy Happy Joy Joy
  • Administrator
  • Hero Member
  • *****
  • Posts: 965
  • Karma: +45/-4
  • Semi-Newbie.
    • View Profile
    • EarthQuake
Re: Disable shadows on particle lights
« Reply #1 on: April 14, 2019, 12:56:18 PM »
Yes.  there should be a key/value you can set to disable shadows on lights.  If it's defined in the weapon def you'd just need to set it there (same key/value the editor uses, forget what it is)

xyzz

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-1
  • Doom Newbie
    • View Profile
Re: Disable shadows on particle lights
« Reply #2 on: April 14, 2019, 09:25:53 PM »
I'm not sure I have not tried. But on the cvars Friar told you about (mtr_light_shader) try adding "noshadows" "1" . Or in case of many fast projectiles lower the light radius so that the lights don't overlap.

EoceneMiacid

  • Full Member
  • ***
  • Posts: 132
  • Karma: +4/-15
    • View Profile
Re: Disable shadows on particle lights
« Reply #3 on: April 16, 2019, 11:47:28 AM »
Yeah, it was indeed pretty straightforward. I just created a new light material, with 'noshadows' set to 1.

Yay, now the plasmagun lights everything up without making my framerate collapse.
« Last Edit: April 16, 2019, 12:17:39 PM by EoceneMiacid »